Hello all,
Upcoming weekend we are going to reset our data switches to use LAG instead of stacking. This way we remove the single point of failure in case of an unexpected stack reload.
I prepared the configs that I want to paste, and I am wondering if I am missing something.
Port Te1/0/1-16 will be used by our blade servers
Port Te1/0/17-18 will be used for LAG ports.
Port Te1/0/20 is our stack port to the data switch
We will use spanning-tree RSTP, and switch 1 had the lowest priority (so will be stack root).
I want to make sure that the switches are configured with the optimal settings, so it would be great of some expert can have an short look at it.
Thanks in advance,
Kind regards,
Max
Switch 1:
configure
no mode simple
no dcb enable
interface out-of-band
ip address 172.30.254.8 255.255.255.0 172.30.254.1
exit
ip domain-name "domain.lan"
line telnet
login authentication default
exit
ip http authentication local
username user password password privilege 15
enable password password
flowcontrol
spanning-tree mode rstp
spanning-tree priority 4096
exit
interface Port-channel 1
mtu 9216
exit
interface range Tengigabitethernet 1/0/17-18
channel-group 1 mode active
exit
interface range tengigabitethernet 1/0/1-16
mtu 9216
switchport mode trunk
switchport access vlan 99
spanning-tree portfast
exit
interface Te1/0/20
mtu 9216
switchport mode trunk
switchport trunk native vlan 99
exit
vlan 10
name "Backup"
exit
vlan 88
name "ISCSI"
exit
vlan 89
name "EQL"
vlan 90
name "Live Migration"
exit
vlan 91
name "CSV"
exit
vlan 99
name "Management"
exit
vlan 999
name "test-lan"
exit
snmp-server location "location"
snmp-server contact "company"
hostname "hostname"
exit
Switch 2:
configure
no mode simple
no dcb enable
interface out-of-band
ip address 172.30.254.9 255.255.255.0 172.30.254.1
exit
ip domain-name "domain.lan"
line telnet
login authentication default
exit
ip http authentication local
username user password password privilege 15
enable password password
flowcontrol
spanning-tree mode rstp
spanning-tree priority 8192
exit
interface Port-channel 1
mtu 9216
exit
interface range Tengigabitethernet 1/0/17-18
channel-group 1 mode active
exit
interface range tengigabitethernet 1/0/1-16
mtu 9216
switchport mode trunk
switchport access vlan 99
spanning-tree portfast
exit
interface Te1/0/20
mtu 9216
switchport mode trunk
switchport trunk native vlan 99
exit
vlan 10
name "Backup"
exit
vlan 88
name "ISCSI"
exit
vlan 89
name "EQL"
vlan 90
name "Live Migration"
exit
vlan 91
name "CSV"
exit
vlan 99
name "Management"
exit
vlan 999
name "test-lan"
exit
snmp-server location "location"
snmp-server contact "company"
hostname "hostname"
exit