Hello,
We are seeing packet loss on our voice network which causes the phone to sometimes ring continuously. This could be the result of oversized packets (more details below). Also on a separate note, if I transfer images using Windows Deployment Service multicast it floods all ports (so I don't do that anymore :-). I had originally enabled IGMP but it previously caused the switch to crash randomly which could have been related to earlier firmware.
We have pretty simple network:
- 3 Dell PC6248s connected in a star topology (1 dist and 2 access switches) interconnected with LAG trunks running latest firmware.
- Several VLANs: voice VLAN (100) for IP phones, production data is on vlan 1, dev on vlan 5.
- IP phones are mainly Aastra 9133i's with a few Polycom's.
I digged in further and we are seeing quite a few "oversized packets" on the LAG trunks. I was wondering if this is causing the packets to drop. If so, should I modify the MTU size to 1522 (I was reading that tagging adds 4 bytes to the default MTU of 1518) or is there a configuration error I'm overlooking somewhere?
show rmon statistics port-channel 1
Port: ch1
Dropped: 0
Octets: 3436040607 Packets: 947867566
Broadcast: 1158102 Multicast: 24535676
CRC Align Errors: 0 Collisions: 0
Undersize Pkts: 0 Oversize Pkts: 43969059
Fragments: 0 Jabbers: 0
64 Octets: 24107589 65 - 127 Octets: 868940536
128 - 255 Octets: 133380606 256 - 511 Octets: 76138498
512 - 1023 Octets: 90380909 1024 - 1518 Octets: 72636117show statistics port-channel 1
Total Packets Received (Octets)................ 175230301131
Packets Received > 1518 Octets................. 43968808
Packets RX and TX 64 Octets.................... 24107385
Packets RX and TX 65-127 Octets................ 868914890
Packets RX and TX 128-255 Octets............... 133371613
Packets RX and TX 256-511 Octets............... 76133886
Packets RX and TX 512-1023 Octets.............. 90379490
Packets RX and TX 1024-1518 Octets............. 72634059
Packets RX and TX 1519-2047 Octets............. 4344763899
Packets RX and TX 2048-4095 Octets............. 0
Packets RX and TX 4096-9216 Octets............. 0
Total Packets Received Without Errors.......... 947838588
Unicast Packets Received....................... 922145059
Multicast Packets Received..................... 24535481
Broadcast Packets Received..................... 1158048
Total Packets Received with MAC Errors......... 0
Jabbers Received............................... 0
Fragments/Undersize Received................... 0
Alignment Errors............................... 0
FCS Errors..................................... 0
Overruns....................................... 0
802.3x Pause Frames Received................... 0
Unacceptable Frame Type........................ 0
Total Packets Transmitted (Octets)............. 6732668920146
Packets Transmitted > 1518 Octets ............. 5827795
Max Frame Size................................. 1518
Total Packets Transmitted Successfully......... 367499338
Unicast Packets Transmitted.................... 4651719996
Multicast Packets Transmitted.................. 5064125
Broadcast Packets Transmitted.................. 5682513
Total Transmit Errors.......................... 0
FCS Errors..................................... 0
Underrun Errors................................ 0
Total Transmit Packets Discarded............... 0
Single Collision Frames........................ 0
Multiple Collision Frames...................... 0
Excessive Collision Frames..................... 0
802.3x Pause Frames Transmitted................ 0
GVRP PDUs received............................. 0
GVRP PDUs Transmitted.......................... 0
GVRP Failed Registrations...................... 0
BPDU: sent 1286910, received 9
Here's the config for our dist switch:
!Current Configuration:
!System Description "PowerConnect 6248, 3.3.6.4, VxWorks 6.5"
!System Software Version 3.3.6.4
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 5,10,15,20,25,50,100,150,200
vlan routing 1 1
vlan routing 5 2
vlan routing 100 3
exit
hostname "SW1-M01"
sntp unicast client enable
sntp server 192.168.0.211
clock summer-time recurring USA zone "CDT"
clock timezone -6 minutes 0 zone "CST"
stack
member 1 2
exit
ip address 192.168.150.250 255.255.255.0
ip address vlan 150
ip domain-name ***
ip name-server 192.168.0.211
ip name-server 192.168.0.212
logging 192.168.0.128
level warning
exit
ip routing
ip route 0.0.0.0 0.0.0.0 192.168.0.253
interface vlan 1
routing
ip address 192.168.0.254 255.255.255.0
exit
interface vlan 5
name "Dev_VLAN"
routing
ip address 192.168.10.254 255.255.255.0
exit
interface vlan 25
name "DSL_VLAN"
exit
interface vlan 100
name "Voice_VLAN"
routing
ip address 10.116.116.2 255.255.252.0
exit
interface vlan 150
name "Management_VLAN"
exit
username "admin" password ---- level 15 encrypted
voice vlan
line telnet
exec-timeout 1800
exit
ip ssh server
spanning-tree priority 4096
!
interface ethernet 1/g1
channel-group 1 mode auto
description 'SWI-M02_Uplink'
lldp transmit-tlv port-desc sys-name sys-desc sys-cap
lldp transmit-mgmt
lldp notification
lldp med confignotification
lldp med transmit-tlv location
lldp med transmit-tlv inventory
exit
!
interface ethernet 1/g2
channel-group 1 mode auto
description 'SWI-M02_Uplink'
lldp transmit-tlv port-desc sys-name sys-desc sys-cap
lldp transmit-mgmt
lldp notification
lldp med confignotification
lldp med transmit-tlv location
lldp med transmit-tlv inventory
exit
-- snipped due to length --
Thanks!