Below is the configuration of the two switches. I have BGP established and up, passing prefixes. I want Switch 1 to send a default gateway to Switch 2 and have the default-originate command setup on the neighbor statement. I do not see the 0.0.0.0 default route in the show ip bgp sum command, but that is detailed in the configuration guide. However, I do not see a default 0.0.0.0 route in the route table for switch 2 at all and receive an error that there is no default route available. What would I be missing here?
Config is below:
SWITCH 1
configure
vlan 50
exit
vlan 50
name "switchtest"
exit
hostname "Switch_1"
slot 1/0 1 ! Dell Networking N3024
stack
member 1 1 ! N3024
exit
ip routing
!
interface loopback 1
ip address 10.0.0.1 255.255.255.255
ip ospf area 0
exit
interface vlan 1
ip address dhcp
exit
interface vlan 50
ip address 172.16.0.1 255.255.255.252
ip ospf area 0
exit
router ospf
router-id 10.0.0.1
network 10.0.0.1 255.255.255.255 area 0
network 172.16.0.0 255.255.255.252 area 0
exit
!
interface Gi1/0/1
description "Switch"
switchport access vlan 50
exit
snmp-server engineid local 800002a203f8b1566f36c4
router bgp 65001
bgp router-id 10.0.0.1
network 172.168.0.0 mask 255.255.255.252
network 10.0.0.1 mask 255.255.255.255
neighbor 172.16.0.2 remote-as 65002
neighbor 172.16.0.2 default-originate
exit
exit
Switch_1#show ip bgp
BGP table version is 7, local router ID is 10.0.0.1
Status Codes: s suppressed, * valid, > best, i - internal
Origin Codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPref Path Origin
------------------- ---------------- ---------- ---------- ------------- ------
*> 172.16.0.0/30 172.16.0.2 1 100 65002 i
*> 192.168.100.0/30 172.16.0.2 1 100 65002 i
*>i 10.0.0.1/32 0.0.0.0 1 100 i
*> 10.0.0.2/32 172.16.0.2 1 100 65002 i
Switch_1#show ip bgp sum
IPv4 Routing .................................. Enable
BGP Admin Mode ................................ Enable
BGP Router ID ................................. 10.0.0.1
Local AS Number ............................... 65001
Traps ......................................... Disable
Maximum Paths ................................. 1
Maximum Paths iBGP ............................ 1
Default Keep Alive Time ....................... 30
Default Hold Time ............................. 90
Number of Network Entries ..................... 4
Number of AS Paths ............................ 1
Default Metric ................................ Not Configured
Default Route Advertise ....................... No
Redistributing:
Source Metric Dist List Route Map
--------- ---------- -------------------------------- --------------------------------
Neighbor ASN MsgRcvd MsgSent State Up/Down Time Pfx Rcvd
---------------- ----- -------- -------- ------------- -------------- ---------
172.16.0.2 65002 78 82 ESTABLISHED 0:00:23:24 3
Switch_1#show ip route
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
C *10.0.0.1/32 [0/1] directly connected, Lo1
B *10.0.0.2/32 [20/1] via 172.16.0.2, Vl50
O 10.0.0.2/32 [110/11] via 172.16.0.2, Vl50
C *172.16.0.0/30 [0/1] directly connected, Vl50
B 172.16.0.0/30 [20/1] via 172.16.0.2, Vl50
B *192.168.100.0/30 [20/1] via 172.16.0.2, Vl50
O 192.168.100.0/30 [110/20] via 172.16.0.2, Vl50
SWITCH 2
configure
vlan 50,100
exit
vlan 50
name "SwitchTest"
exit
vlan 100
name "Switch"
exit
hostname "Switch_2"
slot 1/0 2 ! Dell Networking N3024F
stack
member 1 2 ! N3024F
exit
ip routing
!
interface loopback 0
exit
!
interface loopback 1
ip address 10.0.0.2 255.255.255.255
exit
interface vlan 1
ip address dhcp
exit
interface vlan 50
ip address 172.16.0.2 255.255.255.252
ip ospf area 0
exit
interface vlan 100
ip address 192.168.100.1 255.255.255.252
exit
router ospf
router-id 10.0.0.2
network 10.0.0.2 255.255.255.255 area 0
network 172.16.0.0 255.255.255.252 area 0
network 192.168.100.0 255.255.255.252 area 0
exit
!
interface Gi1/0/23
switchport access vlan 100
exit
!
interface Gi1/0/24
description "Switch"
switchport access vlan 50
exit
snmp-server engineid local 800002a203f8b156530097
router bgp 65002
bgp router-id 10.0.0.2
network 172.16.0.0 mask 255.255.255.252
network 192.168.100.0 mask 255.255.255.252
network 10.0.0.2 mask 255.255.255.255
neighbor 172.16.0.1 remote-as 65001
exit
exit
Switch_2#show ip bgp
BGP table version is 9, local router ID is 10.0.0.2
Status Codes: s suppressed, * valid, > best, i - internal
Origin Codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPref Path Origin
------------------- ---------------- ---------- ---------- ------------- ------
*>i 172.16.0.0/30 0.0.0.0 1 100 i
*>i 192.168.100.0/30 0.0.0.0 1 100 i
*> 10.0.0.1/32 172.16.0.1 1 100 65001 i
*>i 10.0.0.2/32 0.0.0.0 1 100 i
Switch_2#show ip bgp sum
IPv4 Routing .................................. Enable
BGP Admin Mode ................................ Enable
BGP Router ID ................................. 10.0.0.2
Local AS Number ............................... 65002
Traps ......................................... Disable
Maximum Paths ................................. 1
Maximum Paths iBGP ............................ 1
Default Keep Alive Time ....................... 30
Default Hold Time ............................. 90
Number of Network Entries ..................... 4
Number of AS Paths ............................ 1
Default Metric ................................ Not Configured
Default Route Advertise ....................... No
Redistributing:
Source Metric Dist List Route Map
--------- ---------- -------------------------------- --------------------------------
Neighbor ASN MsgRcvd MsgSent State Up/Down Time Pfx Rcvd
---------------- ----- -------- -------- ------------- -------------- ---------
172.16.0.1 65001 83 82 ESTABLISHED 0:00:24:32 1
Switch_2#show ip route
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
B *10.0.0.1/32 [20/1] via 172.16.0.1, Vl50
O 10.0.0.1/32 [110/11] via 172.16.0.1, Vl50
C *10.0.0.2/32 [0/1] directly connected, Lo1
C *172.16.0.0/30 [0/1] directly connected, Vl50
C *192.168.100.0/30 [0/1] directly connected, Vl100
Switch_2#show ip route 0.0.0.0
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
No routes found.