Hi,
I already have port authentication working with dynamic vlan assignment and guest-vlan when authentication is not successful.
My problem is that I want the IP phones (mainly Openstage 40) to be automatically registered within the voice vlan without port authentication. Sadly the phones are not recognized as voice devices and therefore registered within the guest-vlan.
my config is as follows (only the necessary parts):
Gi1/0/1 is working without the voice vlan config
Gi1/0/2 isn't working (not possible is phone is configured for tagging lldp)
Gi1/0/3 isn't working too
dot1x system-auth-control
dot1x system-auth-control monitor
aaa authentication dot1x default radius
aaa authorization network default radius
dot1x dynamic-vlan enable
voice vlan
radius-server host auth this.is.some.ip
primary
name "primary-RadiusServer"
timeout 5
key "something"
exit
radius-server host auth this.is.another.ip
name "2nd-RadiusServer"
timeout 5
key "something
exit
!
interface Gi1/0/1
spanning-tree portfast
spanning-tree guard root
dot1x reauthentication
dot1x timeout guest-vlan-period 15
dot1x max-req 10
dot1x guest-vlan 1001
dot1x unauth-vlan 1001
authentication order dot1x
authentication priority dot1x
exit
!
interface Gi1/0/2
spanning-tree portfast
spanning-tree guard root
dot1x reauthentication
dot1x timeout guest-vlan-period 15
dot1x max-req 10
dot1x guest-vlan 1001
dot1x unauth-vlan 1001
authentication order dot1x
authentication priority dot1x
lldp med confignotification
voice vlan 250
voice vlan auth disable
exit
!
interface Gi1/0/3
spanning-tree portfast
spanning-tree guard root
switchport mode general
switchport general pvid 249
switchport general allowed vlan add 249,251-254,1001
switchport general allowed vlan add 250 tagged
dot1x reauthentication
dot1x timeout guest-vlan-period 15
dot1x max-req 10
dot1x guest-vlan 1001
dot1x unauth-vlan 1001
authentication order dot1x
authentication priority dot1x
lldp med confignotification
voice vlan 250
voice vlan auth disable
exit
!
... isn't there a possibility to define the "oui-table" with the new N2000/N3000/N4000 series?
This N2048P is on the latest available software
Machine Description............... Dell Networking Switch
System Model ID................... N2048P
Machine Type...................... Dell Networking N2048P
Serial Number..................... snip
Manufacturer...................... 0xbc00
Burned In MAC Address............. snip
System Object ID.................. 1.3.6.1.4.1.674.10895.3056
SOC Version....................... BCM56340_A0
HW Version........................ 5
CPLD Version...................... 13
unit active backup current-active next-active
---- ----------- ----------- -------------- --------------
1 6.2.6.6 6.2.0.5 6.2.6.6 6.2.6.6
Thanks