Hello, I'm new in networking and have been tasked with setting up our network with VLANS. We have two Powerconect 6248 switches configured in a stack. We created two VLANS (10, 168) and assigned ip address to both and enalbled routing. We have also enabled ip routing feature of this switch. We can ping within the vlans (vlan10 device to vlan10 device and vlan168 device to vlan168 device), but we cannot ping between vlans.(vlan10 device to vlan168 device). In addition, we can reach (ping) the Internet from a device on vlan10 but we can NOT reach the Internet from a device on vlan168.
MGMT VLAN = VLAN1 (default)......10.1.1.1/24 (connected to firewall X0 port)
VLAN10......10.1.10.1 /24 gw 10.1.10.254 (connected to firewall X3 port)
VLAN168......192.168.168.1 /24 (NOT connected to firewall)
Here is my running config, and thank you in advance.
pc6248_stack#show running-config
!Current Configuration:
!System Description "PowerConnect 6248, 3.3.12.1, VxWorks 6.5"
!System Software Version 3.3.12.1
!Cut-through mode is configured as disabled
!
Configure
vlan database
vlan 10,168
vlan routing 10 1
vlan routing 168 2
exit
ip telnet server disable
hostname "pc6248_stack"
clock timezone -4 minutes 0 zone "EDT"
stack
member 1 2
member 2 2
exit
ip address 10.1.1.5 255.255.255.0
ip default-gateway 10.1.1.1
ip https server
no ip http server
ip routing
ip route 0.0.0.0 0.0.0.0 10.1.10.254
interface vlan 10
name "vlan10"
routing
ip address 10.1.10.1 255.255.255.0
exit
interface vlan 168
name "vlan168"
routing
ip address 192.168.168.1 255.255.255.0
exit
interface ethernet 1/g45
switchport access vlan 168
exit
!
interface ethernet 1/g47
switchport access vlan 10
exit
!
interface ethernet 2/g41
spanning-tree portfast
switchport access vlan 10
exit
!
interface ethernet 2/g45
switchport access vlan 168
exit
!
interface ethernet 2/g47
switchport access vlan 10
exit
We feel as if we are missing some routing commands but we are unsure. It was our understanding that with the configuration listed that we should be able to ping between devices on either vlan (from vlan10 to vlan168 and from vlan168 to vlan10) but that is not working.
Thank you for your assistance.