Hi guys, sorry for the noob post but you are my last hope:
Here is the scenario:
On the Head office I have a Dell PC 6248 with some VLANs and a firewall connected to it doing all the routing.
Now we are opening a branch office, there we have two N1548P and the main office connects to the branch office using a private cloud in bridge mode so there is no need aditional configuration on the uplink.
In this branch office I want to have three VLANs, so:
1- On the 6248 the port used to uplink to the branch office is the 1/g2
2- On the N1548P #1 the port used to uplink with the head office is the 1/g2
3- Between the two N1548P the port g45 is used on both to uplink between them.
4- On the 6248 the firewall is connected to the 1/g9 port
5- The firewall is distributing DHCP for those VLANs
Here my config:
6248
configure
vlan database
vlan 10,20,30
exit
stack
member 1 2
exit
ip address 10.10.0.71 255.255.254.0
interface vlan 10
name "Farmacia"
exit
interface vlan 20
name "CamerasFarmacia"
exit
interface vlan 30
name "Polos"
exit
!
interface ethernet 1/g2
switchport mode general
switchport general allowed vlan add 10,20,30 tagged
exit
!
interface ethernet 1/g9
switchport mode general
switchport general allowed vlan add 10,20,30 tagged
exit
!
On the #1 N1548P
configure
vlan 10,20,30
exit
vlan 10
name "Farmacia"
exit
vlan 20
name "CamerasFarmacia"
exit
vlan 30
name "Polos"
exit
stack
member 1 4 ! N1548P
exit
interface vlan 1
ip address 10.10.0.53 255.255.254.0
exit
interface vlan 30
exit
username "admin" password a1b36ab107f088e70edf50cb3ebb73c8 privilege 15 encrypted
!
interface Gi1/0/2
switchport mode general
switchport general allowed vlan add 10,20,30 tagged
exit
!
interface Gi1/0/10
switchport access vlan 10
!
interface Gi1/0/45
switchport mode general
switchport general allowed vlan add 10,20,30 tagged
exit
!
On the #2 N1548P
configure
vlan 10,20,30
exit
vlan 10
name "Farmacia"
exit
vlan 20
name "CamerasFarmacia"
exit
vlan 30
name "Polos"
exit
stack
member 1 4 ! N1548P
exit
interface vlan 1
ip address 10.10.0.53 255.255.254.0
exit
interface vlan 30
exit
username "admin" password a1b36ab107f088e70edf50cb3ebb73c8 privilege 15 encrypted
!
interface Gi1/0/10
switchport access vlan 20
!
interface Gi1/0/45
switchport mode general
switchport general allowed vlan add 10,20,30 tagged
exit
!
Now the problem is, if I connect a PC on either port Gi1/0/10 I don't get IP address within the respective VLAN. I tried adding ip address to VLANs on each switch but didn't solve so I am lost.
Any help will be appreciated.
Thanks in advance.