Hi,
I am trying to set up VLT domain which will connect downstream to several N-series Switches and upstream to Cisco Router and I am experiencing unusual behavior.
S4048-ON are running 9.10(0.1) software
So VLT itself work but OSPF adjacency with Cisco router will not form when 2 VLT peers are up. As soon as I power off the second peer the ospf adjacency is forming instantly.
Also when 2 peers are alive one of them is very unresponsive (drops packets, and if not the latency is around 500ms), again, when I power off one peer device (doesn't matter which one) everything works just fine.
Is there something wrong in my config or is it a software bug ?
PS Edge switches are connected to Te1/1 - 1/3. Router is connected to Te1/45 and VLTi is configured on Te1/47 and Te1/48... on both VLT peers
Configs for reference:
1st VLT peer:
T1-CSW#sh run
Current Configuration ...
! Version 9.10(0.1)
!
boot system stack-unit 1 primary system: A:
boot system stack-unit 1 secondary system: B:
boot system stack-unit 1 default system: A:
!
hostname T1-CSW
!
protocol lldp
!
redundancy auto-synchronize full
!
[edit]
lacp system-priority 1
!
protocol spanning-tree rstp
no disable
bridge-priority 0
!
!
vlt domain 100
peer-link port-channel 100
back-up destination 10.10.254.2
primary-priority 10
!
stack-unit 1 provision S4048-ON
!
interface TenGigabitEthernet 1/1
no ip address
!
port-channel-protocol LACP
port-channel 1 mode active
no shutdown
!
interface TenGigabitEthernet 1/2
no ip address
!
port-channel-protocol LACP
port-channel 2 mode active
no shutdown
!
interface TenGigabitEthernet 1/3
no ip address
!
port-channel-protocol LACP
port-channel 3 mode active
no shutdown
!
[edit]
!
interface TenGigabitEthernet 1/45
no ip address
switchport
no shutdown
!
interface TenGigabitEthernet 1/46
no ip address
shutdown
!
interface TenGigabitEthernet 1/47
no ip address
no shutdown
!
interface TenGigabitEthernet 1/48
no ip address
no shutdown
!
[edit]
!
interface Port-channel 1
no ip address
switchport
vlt-peer-lag port-channel 1
no shutdown
!
interface Port-channel 2
no ip address
switchport
vlt-peer-lag port-channel 2
no shutdown
!
interface Port-channel 3
no ip address
switchport
vlt-peer-lag port-channel 3
no shutdown
!
interface Port-channel 100
no ip address
channel-member TenGigabitEthernet 1/47-1/48
no shutdown
!
interface Vlan 1
!untagged Port-channel 100
!
interface Vlan 2
ip address 192.0.0.1/16
tagged Port-channel 1-3
no shutdown
!
interface Vlan 3
ip address 172.0.0.1/16
tagged Port-channel 1-3
no shutdown
!
interface Vlan 4
ip address 10.0.1.1/24
tagged Port-channel 1
no shutdown
!
interface Vlan 5
no ip address
tagged Port-channel 1
no shutdown
!
interface Vlan 8
ip address 10.10.8.1/23
tagged TenGigabitEthernet 1/17
tagged Port-channel 1-3
no shutdown
!
interface Vlan 40
ip address 10.10.40.1/22
tagged Port-channel 1-3
no shutdown
!
interface Vlan 98
ip address 10.10.90.2/24
no shutdown
!
interface Vlan 240
ip address 10.10.240.1/22
tagged Port-channel 1-3
no shutdown
!
interface Vlan 997
no ip address
tagged Port-channel 1-3
no shutdown
!
interface Vlan 999
ip address 10.255.10.10/24
tagged TenGigabitEthernet 1/45
tagged Port-channel 45
no shutdown
!
interface Vlan 1001
ip address 10.10.254.1/24
no shutdown
!
router ospf 1
router-id 10.255.10.10
network 10.10.8.0/23 area 0
network 10.255.10.0/24 area 0
passive-interface default
no passive-interface Vlan 999
!
[edit]
!
end
-----------------------------------------------------------
2nd VLT Peer:
T2-CSW#sh run
Current Configuration ...
! Version 9.10(0.1)
!
boot system stack-unit 1 primary system: A:
boot system stack-unit 1 secondary system: B:
boot system stack-unit 1 default system: A:
!
logging monitor informational
!
hostname T2-CSW
!
protocol lldp
!
redundancy auto-synchronize full
!
[edit]
lacp system-priority 1
!
protocol spanning-tree rstp
no disable
bridge-priority 4096
!
vlt domain 100
peer-link port-channel 100
back-up destination 10.10.254.1
primary-priority 20
!
stack-unit 1 provision S4048-ON
!
interface TenGigabitEthernet 1/1
no ip address
!
port-channel-protocol LACP
port-channel 1 mode active
no shutdown
!
interface TenGigabitEthernet 1/2
no ip address
!
port-channel-protocol LACP
port-channel 2 mode active
no shutdown
!
interface TenGigabitEthernet 1/3
no ip address
!
port-channel-protocol LACP
port-channel 3 mode active
no shutdown
!
[edit]
!
interface TenGigabitEthernet 1/45
no ip address
switchport
no shutdown
!
interface TenGigabitEthernet 1/46
no ip address
no shutdown
!
interface TenGigabitEthernet 1/47
no ip address
no shutdown
!
interface TenGigabitEthernet 1/48
no ip address
no shutdown
!
[edit]
!
interface Port-channel 1
no ip address
switchport
vlt-peer-lag port-channel 1
no shutdown
!
interface Port-channel 2
no ip address
switchport
vlt-peer-lag port-channel 2
no shutdown
!
interface Port-channel 3
no ip address
switchport
vlt-peer-lag port-channel 3
no shutdown
!
interface Port-channel 10
no ip address
no shutdown
!
interface Port-channel 100
no ip address
channel-member TenGigabitEthernet 1/47-1/48
no shutdown
!
interface Vlan 1
!untagged Port-channel 100
!
interface Vlan 2
ip address 192.0.0.2/16
tagged Port-channel 1-3
no shutdown
!
interface Vlan 3
ip address 172.0.0.2/16
tagged Port-channel 1-3
no shutdown
!
interface Vlan 4
ip address 10.0.1.2/24
tagged Port-channel 1
no shutdown
!
interface Vlan 5
no ip address
tagged Port-channel 1
no shutdown
!
interface Vlan 8
ip address 10.10.8.2/23
tagged TenGigabitEthernet 1/17
tagged Port-channel 1-3
no shutdown
!
interface Vlan 40
ip address 10.10.40.2/22
tagged Port-channel 1-3
no shutdown
!
interface Vlan 98
ip address 10.10.90.1/24
no shutdown
!
interface Vlan 240
ip address 10.10.240.2/22
tagged Port-channel 1-3
no shutdown
!
interface Vlan 997
no ip address
tagged TenGigabitEthernet 1/45
tagged Port-channel 1-3
no shutdown
!
interface Vlan 999
ip address 10.255.10.11/24
tagged TenGigabitEthernet 1/45
no shutdown
!
interface Vlan 1001
ip address 10.10.254.2/24
no shutdown
!
router ospf 1
router-id 10.255.10.11
network 10.10.8.0/23 area 0
network 10.255.10.0/24 area 0
passive-interface default
no passive-interface Vlan 999
!
ip ssh server enable
ip ssh server version 2
!
line console 0
logging synchronous level 2 limit 20
line vty 0
line vty 1
line vty 2
line vty 3
line vty 4
line vty 5
line vty 6
line vty 7
line vty 8
line vty 9
!
reload-type
boot-type normal-reload
config-scr-download enable
!
end
T2-CSW#
--------------------------------------------------------------
Cisco Router:
Router#sh run
Building configuration...
Current configuration : 2042 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
voice-card 0
no dspfarm
!
bridge irb
!
!
!
interface Loopback0
ip address 8.8.8.8 255.255.255.255
!
interface GigabitEthernet0/0
mtu 1500
no ip address
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/0.999
encapsulation dot1Q 999
no snmp trap link-status
bridge-group 255
bridge-group 255 spanning-disabled
!
interface GigabitEthernet0/1
mtu 1500
no ip address
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1.999
encapsulation dot1Q 999
no snmp trap link-status
bridge-group 255
bridge-group 255 spanning-disabled
!
interface BVI255
ip address 10.255.10.2 255.255.255.0
ip ospf 1 area 0
!
router ospf 1
router-id 10.255.10.2
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.0.0.255 area 0
!
ip classless
!
[edit]
!
control-plane
!
bridge 253 route ip
bridge 255 route ip
!
[edit]
!
end