Hello all,
I know what I'm trying to do is theoretical extremely simple and basic, but I've spent an inordinate amount of time trying to figure this out and am getting nowhere.
What I have is a very simple test situation with a voice VLAN with Shoretel phones, with VLAN 1 as the data VLAN and 20 as the Voice VLAN.
DHCP Server connect to switchport #1:
Windows Server 2008 (10.1.10.23 /23)
Scope #1 (Data VLAN)
- 10.1.10.100-200 /23
- 003 Router 10.1.10.98 (the switch interface for VLAN 1)
- 006 DNS Servers 10.1.10.4,10.1.11.9
- 015 DNS Domain Name company.com
- 156 Shoretel "ftpservers=10.1.10.80,country=1,language=1,layer2tagging=1,vlanid=20"
Scope #2 (Voice VLAN)
- 2.2.2.100-200 /24
- 003 Router 2.2.2.1 (the switch interface for VLAN 20)
- 006 DNS Servers 10.1.10.4,10.1.11.9
- 015 DNS Domain Name company.com
- 156 Shoretel "ftpservers=10.1.10.80,country=1,language=1,layer2tagging=1,vlanid=20"
The way Shoretel phones work is they come up untagged, grab a DHCP address, look at option 156, then release their address. If option 156 specifies VLAN tagging, it turns that on and reboots with the new tag.
So here's my very, very basic switch config:
vlan 20
name "Voice VLAN"
exit
ip routing
interface vlan 1
ip address 10.1.10.98 255.255.254.0
exit
interface vlan 20
ip address 2.2.2.1 255.255.255.0
ip helper-address 10.1.10.23
interface Gi1/0/1 - no config / default access mode VLAN 1
description "DHCP server"
exit
interface range Gi1/0/2-22
switchport mode general
switchport general allowed vlan add 20
exit
On port #5, I have a laptop which receives a proper VLAN 1 DHCP address.
On port #7, I have a Shoretel phone with a computer daisy-chained off it. This computer receives a VLAN 1 DHCP address just fine.
On port #9, I have a Shoretel phone with no computer attached.
With both phones, they initially boot up and get VLAN 1 addresses. They they say "reconfiguring network", which is what they do when they switch VLAN, but then they just sit there requesting a DHCP address. I've tried "vlan add 20" and "vlan add 20 tagged" both, with no change in results.
The DHCP server log shows the initial VLAN 1 address assignments and releases, but that's it.
show ip helper-address shows:
Interface: Vl20
UDP Port: Default
Discard: No
Hit Count: 211
Server Address 10.1.10.23
What incredibly simple and obvious thing am I missing here? TIA