Hi,
Apologies if this is a stupid question, but I have a client with 3 geographically separate sites who wants to have an N3024 at each site and also have them talk to each other. These switches each have an ESXi box and EQL storage box attached. They need to replicate between each other.
Each site has 4 IP ranges available...all on a 10.148.x.x
Site 1 uses 10.148.1.x and 10.148.3.x, Site 2 uses 10.148.9.x and 10.148.11.x and Site 3 uses 10.148.13.x and 10.148.15.x
The vLans in question for each site will be the third octet, so we have vLans 3, 9, 11 etc.
My question is how to get them to route the vLans to each other correctly. I have read what I can find online and I'm still confused. Most documentation seems to suggest the use of a Layer 3 device in the middle of everything, but these N3024s are already layer 3 right?
It's also suggested that each vLan have it's own IP. Which I have done...but do I need to assign the vLan IP on every switch or just the one to which the vLan is native? Example - site3 uses 10.148.3.x and so I have created and assigned that vLan an IP on that switch, but do I need to assign that vLan an IP on the other switches? If I do then I get all sorts of IP conflict messages, but if I don't then the switches are unable to ping their neighbours vLan addresses.
This is a part config I have used. I know it's going to be something simple that I am missing, but I have been looking at this for a while now and have got to the point where I can't see the wood for the trees.
ip routing
interface vlan 1
exit
interface vlan 3
exit
interface vlan 9
ip address 10.148.9.20 255.255.255.0
exit
interface vlan 11
ip address 10.148.11.20 255.255.255.0
exit
interface vlan 13
exit
interface vlan 15
exit
I have set port 1 to trunk and allowed all the vLans through, and set the rest of the ports to 'general' mode. I also tried 'access' but this didn't seem to work either.
interface Gi1/0/1
switchport mode trunk
switchport general allowed vlan add 3,9,11,13,15 tagged
switchport general allowed vlan add 1 tagged
exit
!
interface Gi1/0/2
switchport mode general
exit
...etc
So...can anyone help? Could anyone provide an exact config for how to route vLans between switches? Can I do it with only three N3024s or do I need another device in there somewhere? What is the correct settings for the ports? Should one switch act as a master switch and hold all IPs for all vLans, or should each switch hold only the vLans local to that site? And where does the default gateway fit into all this - do I need one for each vLan?
Thanks in advance for any assistance.
Duncan