I'm having the hardest time getting a 6248 switch to work with vlans. I originally hooked up two 5448's and got vlan2 going nicely between them. I stuck the 6248 in between the two 5400's thinking there wouldn't be much more to it. But it doesn't work at all. Even to where I can't ping the vlan interface on the 6248 that's configured on itself! Any ideas are welcomed. Thanks
The physical ports and wiring goes like so:
Switch A (port 1/0/47) <-> (port 1/g28) Switch C (port 1/xg4) <-> (port 1/0/2) Switch B
Here are the configs for each switch. I pulled a few things out but this should cover the primary configs as they relate. If I make the uplink ports on Switch C, the 6248, trunk ports, it just stops talking to the switch on the other end entirely. General seems to only way to keep it working.
Switch A (5548)
vlan database
vlan 2,10
exit
!
interface vlan 1
ip address 10.88.16.59 255.255.255.0
!
interface vlan 2
ip address 10.16.1.3 255.255.255.0
!
interface gigabitethernet1/0/1
switchport access vlan 2
!
interface gigabitethernet1/0/47
switchport mode trunk
!
ip route 0.0.0.0 0.0.0.0 10.88.162.29
Switch B (5548)
vlan database
vlan 2,10,20
exit
!
interface vlan 1
ip address 10.88.16.25 255.255.255.0
ip address 172.16.16.25 255.255.255.0
!
interface vlan 2
ip address 10.16.1.25 255.255.255.0
!
interface tengigabitethernet1/0/2
description uplinkto.5
switchport mode trunk
ip route 0.0.0.0 0.0.0.0 10.88.16.1
Switch C (6248)
vlan database
vlan 2,10-11
vlan routing 2 1
exit
ip address 10.88.162.5 255.255.255.0
ip default-gateway 10.88.162.1
interface vlan 2
routing
ip address 10.16.1.5 255.255.255.0
exit
interface ethernet 1/g28
switchport mode general
switchport general allowed vlan add 2
exit
interface ethernet 1/xg4
description '1stflBack'
switchport mode general
switchport general allowed vlan add 2,10
exit