In the next few months we'll be replacing our network gear. I was able to get my hands on the new gear early, and though I'm not traditionally a network guy, the project has been given to me, and I starting to play around. The first thing I wanted to work on was setting up VLANs. I've set the switches up like the image below:
Image may be NSFW.
Clik here to view.
When I IP all the connected PCs on the same subnet, and apply VLAN10 to their respective ports, they are not pingable within the same stack or between stacks. My basic understanding is that they should be, shouldn't they? Am I missing something in my understanding of VLANs or is there a problem with my configs? I've posted the configs below.
RTTMOACCESS01 config:
vlan database
vlan 10,20,30,40,50
exit
voice vlan oui-table add 000181 Nortel__________________
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 001049 Shoretel________________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00907a Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0
iscsi target port 3260 address 0.0.0.0
iscsi target port 9876 address 0.0.0.0
iscsi target port 20002 address 0.0.0.0
iscsi target port 20003 address 0.0.0.0
iscsi target port 25555 address 0.0.0.0
hostname rttmoaccess01
no logging console
privilege 15
!
interface vlan 10
name IT
!
interface vlan 20
name UserPCs
!
interface vlan 30
name UserTCs
!
interface vlan 40
name Voice
!
interface vlan 50
name Printers
!
interface gigabitethernet1/0/1
switchport access vlan 10
!
interface tengigabitethernet1/0/1
switchport mode general
switchport general allowed vlan add 10 tagged
switchport general allowed vlan add 20 tagged
switchport general allowed vlan add 30 tagged
switchport general allowed vlan add 40 tagged
switchport general allowed vlan add 50 tagged
!
interface gigabitethernet2/0/1
switchport access vlan 10
!
interface tengigabitethernet2/0/1
switchport mode general
switchport general allowed vlan add 10 tagged
switchport general allowed vlan add 20 tagged
switchport general allowed vlan add 30 tagged
switchport general allowed vlan add 40 tagged
switchport general allowed vlan add 50 tagged
!
Default settings:
Service tag: 76BYTS1
SW version 4.1.0.8 (date 28-Aug-2012 time 11:17:36)
Gigabit Ethernet Ports
=============================
speed 1000
duplex full
negotiation
flow-control on
mdix auto
no back-pressure
interface vlan 1
interface port-channel 1 - 32
spanning-tree
spanning-tree mode RSTP
qos basic
qos trust cos
eee enable
RTTMOACCESS02 config:
vlan database
vlan 10,20,30,40,50
exit
voice vlan oui-table add 000181 Nortel__________________
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 001049 Shoretel________________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00907a Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0
iscsi target port 3260 address 0.0.0.0
iscsi target port 9876 address 0.0.0.0
iscsi target port 20002 address 0.0.0.0
iscsi target port 20003 address 0.0.0.0
iscsi target port 25555 address 0.0.0.0
hostname rttmoaccess01
no logging console
privilege 15
!
interface vlan 10
name IT
!
interface vlan 20
name UserPCs
!
interface vlan 30
name UserTCs
!
interface vlan 40
name Voice
!
interface vlan 50
name Printers
!
interface gigabitethernet1/0/1
switchport access vlan 10
!
interface tengigabitethernet1/0/1
switchport mode general
switchport general allowed vlan add 10 tagged
switchport general allowed vlan add 20 tagged
switchport general allowed vlan add 30 tagged
switchport general allowed vlan add 40 tagged
switchport general allowed vlan add 50 tagged
!
interface gigabitethernet2/0/1
switchport access vlan 10
!
interface tengigabitethernet2/0/1
switchport mode general
switchport general allowed vlan add 10 tagged
switchport general allowed vlan add 20 tagged
switchport general allowed vlan add 30 tagged
switchport general allowed vlan add 40 tagged
switchport general allowed vlan add 50 tagged
!
Default settings:
Service tag: 76BYTS1
SW version 4.1.0.8 (date 28-Aug-2012 time 11:17:36)
Gigabit Ethernet Ports
=============================
speed 1000
duplex full
negotiation
flow-control on
mdix auto
no back-pressure
interface vlan 1
interface port-channel 1 - 32
spanning-tree
spanning-tree mode RSTP
qos basic
qos trust cos
eee enable
RTTMOCORE config
! Version 8.3.12.0
! Last configuration change at Fri Jun 14 13:31:58 2013 by default
! Startup-config last updated at Fri Jun 14 13:32:40 2013 by default
!
boot system stack-unit 0 primary system: A:
boot system stack-unit 0 secondary system: B:
boot system stack-unit 0 default system: A:
boot system stack-unit 1 primary system: A:
boot system stack-unit 1 secondary system: B:
boot system stack-unit 1 default system: A:
!
redundancy auto-synchronize full
!
hardware watchdog
!
no logging console
!
hostname rttmocore
!
stack-unit 0 provision S4810
!
stack-unit 0 stack-group 14
!
stack-unit 0 stack-group 15
!
interface TenGigabitEthernet 0/46
no ip address
switchport
flowcontrol rx on tx off
no shutdown
!
interface TenGigabitEthernet 0/47
no ip address
switchport
flowcontrol rx on tx off
no shutdown
stack-unit 1 provision S4810
!
stack-unit 1 stack-group 14
!
stack-unit 1 stack-group 15
!
interface TenGigabitEthernet 1/46
no ip address
switchport
flowcontrol rx on tx off
no shutdown
!
interface TenGigabitEthernet 1/47
no ip address
switchport
flowcontrol rx on tx off
no shutdown
!
!
interface Vlan 1
!
interface Vlan 10
description IT
name IT
no ip address
tagged TenGigabitEthernet 0/46-47
tagged TenGigabitEthernet 1/46-47
shutdown
!
interface Vlan 20
description UserPCs
name UserPCs
no ip address
shutdown
!
interface Vlan 30
description UserTCs
name UserTCs
no ip address
shutdown
!
interface Vlan 40
description Voice
name Voice
no ip address
shutdown
!
interface Vlan 50
description Printers
name Printers
no ip address
shutdown
!
protocol lldp
!
line console 0
line vty 0
line vty 1
line vty 2
line vty 3
line vty 4
line vty 5
line vty 6
line vty 7
line vty 8
line vty 9
!
end