I am CCNA and my background is primarily in Cisco. I have been moved into a new shop that deploys Dell for their residential/MDU internet. I am having some trouble getting OSPF to establish. First strange thing I've found is there is no "router ospf _process ID_" command to establish an OSPF process ID.
Second is that I can not find a way to set an IP on an interface itself. I can only create layer 3 connectivity between the two switches by putting each interface into a vlan (50 in this case) with an IP on the vlan.
I can ping the /30 between the routers and see the route via show ip route because it is directly connected, but I can not ping the opposite router's loopback IP, nor do I see it in the show ip route.
I do not have access to the switches at the moment. They are at the office. Looking at the config I don't seem to have "ip routing" turned on on switch 2. Is that my problem?
My configuration is below:
1
!Current Configuration:
!System Description "Dell Networking N3024, 6.1.0.6, Linux 3.6.5-320b2282"
!System Software Version 6.1.0.6
!
configure
vlan 50
name "Switchtest"
exit
vlan 50
exit
hostname "Switch_1"
slot 1/0 1 ! Dell Networking N3024
stack
member 1 1 ! N3024
exit
ip routing
interface vlan 1
ip address dhcp
exit
interface vlan 50
ip address 172.16.0.1 255.255.255.252
ip ospf area 0
exit
router ospf
router-id 10.0.0.1
network 192.168.10.0 255.255.255.0 area 0
network 10.0.0.1 255.255.255.255 area 0
network 172.16.0.0 255.255.255.252 area 0
exit
!
interface Gi1/0/1
description "Switch"
switchport access vlan 50
exit
!
interface loopback 1
ip address 10.0.0.1 255.255.255.255
exit
snmp-server engineid local 800002a203f8b1566f36c4
exit
2
!Current Configuration:
!System Description "Dell Networking N3024F, 6.1.0.6, Linux 3.6.5-320b2282"
!System Software Version 6.1.0.6
!
configure
vlan 50
name "SwitchTest"
exit
vlan 50
exit
hostname "Switch_2"
slot 1/0 2 ! Dell Networking N3024F
stack
member 1 2 ! N3024F
exit
interface vlan 1
ip address dhcp
exit
interface vlan 50
ip address 172.16.0.2 255.255.255.252
ip ospf area 0
exit
router ospf
router-id 10.0.0.2
network 10.0.0.2 255.255.255.255 area 0
network 172.16.0.0 255.255.255.252 area 0
exit
!
interface Gi1/0/24
description "Switch"
switchport access vlan 50
exit
!
interface loopback 0
exit
!
interface loopback 1
ip address 10.0.0.2 255.255.255.255
exit
snmp-server engineid local 800002a203f8b156530097
exit
I assume the below problem is due to lacking "ip routing" on Switch 2:
Switch_2#show ip ospf area 0
OSPF must first be initialized for the switch.
Switch_1#show ip route 10.0.0.2
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
No routes found.
Switch_1#configure t
Switch_1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.2
The static route will not take effect until a routing interface
belonging to the same subnet as the next hop IP is created and activated.
I have an SVI with an IP that is up and can ping across it, but this leads me to believe I need an IP on an actual physical interface. But so far I can not figure out how to do this.
Also, no "router bgp" function seems to be present, but Dell sent these two us as BGP capable routers.
I would appreciate a link to an N3024 configuration guide, especially on BGP. Any links to relevant material would be greatly appreciated.