Hi guys,
I'm having alot of difficulty trying to configure what I thought would be a very basic VLAN exercise, I'm in dire straits and could use some sage advice.
Basically I'm installing a new voip phone system and I'm attempting to segregate traffic (and broadcasts) between the two.
Everything is connected into a switch stack of one 6224 and one 6248. I've been trying to test this using a test VLAN and the VOIP VLAN before I touch my productive network which is sitting untouched on the default management VLAN 1.
My firewall is a cisco ASA 5510 which is managed by my ISP, so I've been testing with an ADSL router which I manage which sits on 10.16.0.251 and configured a static route for the vlans in there (although not sure if correct!).
My setup is as follows:
Data (Workstations/Servers): 10.16.0.x/24 (VLAN 1)
VOIP: 10.16.100.x/24 (VLAN 100)
Firewall: 10.16.0.254 (VLAN 1)
Test VLAN interface: 10.16.5.1 (VLAN 5)
VOIP VLAN interface: 10.16.100.2 (VLAN 100)
Interface 1/g15 and 2/g46 are two ports which I've connected laptops to for testing purposes. If anyone could please cast their eye over the below and offer any advice or pointers on what I'm doing wrong, it'd be very very much appreciated, thanks!
console#show running-config
!Current Configuration:
!System Description "Dell 48 Port Gigabit Ethernet, 2.0.0.12, VxWorks5.5.1"
!System Software Version 2.0.0.12
!
configure
vlan database
vlan 5, 100
exit
stack
member 1 1
member 2 2
exit
ip address 10.16.0.27 255.255.255.0
ip default-gateway 10.16.0.254
logging file debug
logging buffered debug
ip routing
ip route 0.0.0.0 0.0.0.0 10.16.0.251
interface vlan 5
name "datatest"
routing
ip address 10.16.5.1 255.255.255.0
exit
interface vlan 100
name "voice"
routing
ip address 10.16.100.2 255.255.255.0
exit
username "admin" password bbcb6cae332cdd76783252b4e7e5d0c8 level 15 encrypted
spanning-tree mst configuration
name "00-1E-C9-9A-58-6D"
exit
!
interface ethernet 1/g15
switchport mode general
switchport general pvid 5
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 100
exit
!
interface ethernet 2/g46
switchport mode general
switchport general pvid 100
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 5
exit
snmp-server user admin READ_noAuthNoPriv
exit