I'm trying to get a normal etherchannel working between ESX (Version 6) and a N4032F Stack.
I'm using 2x 10Gb/s links. After connecting the second link and waiting 3-4 seconds the host can't be pinged anymore. Disabling / unplugging 1 link get`s it working again.
My config looks like this on N4032F:
interface port-channel 1
description "esx"
hashing-mode 6
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 200,300
interface Te1/0/1
channel-group 1 mode on
description "esx"
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 200,300
interface Te2/0/1
channel-group 1 mode on
description "esx"
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 200,300
On the ESX it`s just a vswitch with those 2 NICs and load balancing set to "Route on ip hash".
BTW, this config works fine with my cisco stack:
interface Port-channel1
description esx1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,200,300
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
interface TenGigabitEthernet1/0/1
description esx1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,200,300
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
channel-group 1 mode on
interface TenGigabitEthernet2/0/1
description esx1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,200,300
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
channel-group 1 mode on