I followed the guide to set up a switchport in General mode on my N2048P to support voice and data vlans on the same port. My IP phones will get a DHCP IP address and I can make calls, however, data devices such as a laptop do not get an IP address via DHCP, and setting a static IP address doesn't work either. Below is my config:
configure
vlan 2-3,7,20-22,30
exit
vlan 2
name "Network"
exit
vlan 3
name "Wireless"
exit
vlan 7
name "Warehouse_PCs/Printers"
exit
vlan 20
name "Wireless_WMS"
exit
vlan 21
name "Wireless_Office"
exit
vlan 22
name "Wireless_Guest"
exit
vlan 30
name "Phones"
exit
ip telnet server disable
hostname "TBG_WHSE_IDF_01A"
slot 1/0 9 ! Dell Networking N2048P
sntp unicast client enable
sntp server 10.2.0.100
clock summer-time recurring USA
clock timezone -5 minutes 0
stack
member 1 9 ! N2048P
exit
ip domain-name "XXXXXX"
no ip http server
ip http secure-server
interface vlan 2
ip address 10.2.2.201 255.255.255.0
exit
ip default-gateway 10.2.2.1
voice vlan
ip ssh server
ip ssh protocol 2
spanning-tree mode pvst
classofservice dot1p-mapping 5 5
cos-queue min-bandwidth 0 0 5 5 10 30 40
!
interface Gi1/0/1
cos-queue strict 5
spanning-tree portfast
switchport mode general
switchport general pvid 7
switchport general allowed vlan add 7
switchport general allowed vlan add 30 tagged
voice vlan 30
voice vlan auth disable
exit
!
interface Gi1/0/47
cos-queue strict 5
spanning-tree portfast
switchport mode general
switchport general pvid 7
switchport general allowed vlan add 7
switchport general allowed vlan add 30 tagged
voice vlan 30
voice vlan auth disable
exit
!
interface Gi1/0/48
switchport mode trunk